30代無職のロズ雑記

30代無職で高卒ニートの職歴なし絶望的人生。社会不適合者で真面目系のクズです。そんな人生をエンターニートで逆転するブログ。最近はグルメリポートが中心で田園都市線沿いの美味しいお店をご紹介しちゃってます。

ptengine

IT

Railsチュートリアル20分トレーニング5日目 【第1章】1.3.1 Bundler〜

Ruby on Rails Tutorial 5日

第1章(1.3.1 Bundler)

uglifierバージョン1.3.0以上の最新バージョンのインストール

gem 'uglifier', '>= 1.3.0'

coffee-railsバージョン4.0.0より大きく、4.1より小さい場合にインストール
つまりマイナーナンバーの部分に相当するアップデート済みのgemをインストール

gem 'coffee-rails', '~> 4.0.0'

経験上ちょっとしたマイナーアップグレードですら問題を引き起こすことがある
Railsチュートリアルではバージョンをがっちり固定

とのこと 筆者もバージョンを固定しました

$ cd hello_app
$ bundle install

しかし、下記のエラーが起きました

Bundler could not find compatible versions for gem "actionpack":
  In snapshot (Gemfile.lock):
    actionpack (= 5.1.5)
・
・
・
Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.

おそらく、依存関係の組み合わせで誤りがあるようでGemfile.lockをupdateするように言われた

なぜかrailsも5.1.5でインストールされてるw

$ bin/rails -v
Rails 5.1.5
$ bundle update

成功したようだ

Using turbolinks-source 5.1.0
Fetching turbolinks 5.0.1 (was 5.1.0)
Installing turbolinks 5.0.1 (was 5.1.0)
Fetching uglifier 3.2.0 (was 4.1.6)
Installing uglifier 3.2.0 (was 4.1.6)
Using web-console 3.5.1
Bundle updated!

いろいろとハマってしまう部分があったがよしとするかw

ロズ
まだ1章が終わらんのかよw

-IT
-,