30代無職のロズ雑記

30代無職で高卒ニートの職歴なし絶望的人生。社会不適合者で真面目系のクズです。そんな人生をエンターニートで逆転するブログ。最近はグルメリポートが中心で田園都市線沿いの美味しいお店をご紹介しちゃってます。

ptengine

MAMP

MacのPHPをMAMPのPHPへ

2016/08/28

MacにはあらかじめPHPがインストールされています。しかし、それが必ずしも最新のCakePHP3が推奨するPHPのバージョンとは限りません。よって今回、最新バージョンのPHPを使用します。

前提条件

要件

  • CakePHP3が推奨する最新のPHPバージョンとする
  • MacのデフォルトPHPは残す

ターミナルで下記のコマンドからPHPの所在を確認します。

$ which php

「/usr/bin/php」とMacにデフォルトで入っているPHPが表示されます。
次にデフォルトで使用するPHPをMAMPに変更します。
vimでbash_profileを開きます。

$ vim ~/.bash_profile

次に下記の1行を追加します。

export PATH=/Applications/MAMP/bin/php/php7.0.0/bin:$PATH

php7.0.0の部分はダウンロードしたMAMPによって異なります。MAMPの設定画面をご確認ください。

変更を保存したら下記のコマンドで設定を再読み込みします。

$ source ~/.bash_profile

下記のコマンドで再度、PHPの所在を確認します。

$ which php

すると「/Applications/MAMP/bin/php/php7.0.0/bin/php」と返ってきます。つまりMAMPでインストールしたPHPが使われるようになります。

以上です。ではアディオス!!

腹出しエセアカ

-MAMP